Description

This script checks if your server configuration meets the requirements for running Yii Web applications. It checks if the server is running the right version of PHP, if appropriate PHP extensions have been loaded, and if php.ini file settings are correct.

Conclusion

Your server configuration satisfies the minimum requirements by Yii. Please pay attention to the warnings listed below if your application will use the corresponding features.

Details

NameResultRequired ByMemo
PHP version Passed Yii Framework PHP 5.1.0 or higher is required.
$_SERVER variable Passed Yii Framework  
Reflection extension Passed Yii Framework  
PCRE extension Passed Yii Framework  
SPL extension Passed Yii Framework  
DOM extension Passed CHtmlPurifier, CWsdlGenerator  
PDO extension Passed All DB-related classes  
PDO SQLite extension Passed All DB-related classes Required for SQLite database.
PDO MySQL extension Passed All DB-related classes Required for MySQL database.
PDO PostgreSQL extension Warning All DB-related classes Required for PostgreSQL database.
PDO Oracle extension Warning All DB-related classes Required for Oracle database.
PDO MSSQL extension (pdo_mssql) Warning All DB-related classes Required for MSSQL database from MS Windows
PDO MSSQL extension (pdo_dblib) Passed All DB-related classes Required for MSSQL database from GNU/Linux or other UNIX.
PDO MSSQL extension (pdo_sqlsrv) Warning All DB-related classes Required for MSSQL database with the driver provided by Microsoft.
Memcache extension Warning CMemCache  
APC extension Warning CApcCache  
Mcrypt extension Warning CSecurityManager Required by encrypt and decrypt methods.
SOAP extension Passed CWebService, CWebServiceAction  
GD extension with
FreeType support
or ImageMagick
extension with
PNG support
Passed CCaptchaAction  
Ctype extension Passed CDateFormatter, CDateTimeParser, CTextHighlighter, CHtmlPurifier  
Fileinfo extension Passed CFileValidator Required for MIME-type validation
 passed  failed  warning